Microsoft releases out-of-band patch for Kerberos

Microsoft has released an out-of-band patch for vulnerability MS14-068.

This vulnerability is rated as critical and could allow for escalation of privileges.
System owners are advised to patch their Domain Controller servers as soon as possible.

Microsoft has advised that all Windows servers should be patched as a precaution, however the Domain Controller servers are significantly higher priority.

Recommended Link

http://blogs.technet.com/b/srd/archive/2014/11/18/additional-information-about-cve-2014-6324.aspx

Other Links

Microsoft Security Bulletin:
https://technet.microsoft.com/en-us/library/security/MS14-068

US-CERT:
https://www.us-cert.gov/ncas/current-activity/2014/11/18/Microsoft-Releases-Patch-MS14-068-Vulnerability